cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "T Jake Luciani (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-9630) Killing cassandra process results in unclosed connections
Date Wed, 11 May 2016 15:58:12 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-9630?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15280325#comment-15280325
] 

T Jake Luciani commented on CASSANDRA-9630:
-------------------------------------------

This is likely the lack of MessageService not setting SO_LINGER to 0 on the sockets.

> Killing cassandra process results in unclosed connections
> ---------------------------------------------------------
>
>                 Key: CASSANDRA-9630
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9630
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Distributed Metadata, Streaming and Messaging
>            Reporter: Paulo Motta
>            Assignee: Paulo Motta
>            Priority: Minor
>             Fix For: 3.x
>
>
> After upgrading from Cassandra from 2.0.12 to 2.0.15, whenever we killed a cassandra
process (with SIGTERM), some other nodes maintained a connection with the killed node in the
CLOSE_WAIT state on port 7000 for about 5-20 minutes.
> So, when we started the killed node again, other nodes could not establish a handshake
because of the connections on the CLOSE_WAIT state, so they remained on the DOWN state to
each other until the initial connection expired.
> The problem did not happen if I ran a nodetool disablegossip before killing the node.
> I was able to fix this issue by reverting the CASSANDRA-8336 commits (including CASSANDRA-9238).
After reverting this, cassandra now closes connection correctly when killed with -TERM, but
leaves connections on CLOSE_WAIT state if I run nodetool disablethrift before killing the
nodes.
> I did not try to reproduce the problem in a clean environment.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message