cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tianon Gravi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-11661) Cassandra 2.0 and later require Java 7u25 or later - jdk 101
Date Tue, 26 Apr 2016 23:27:12 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-11661?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15259164#comment-15259164
] 

Tianon Gravi commented on CASSANDRA-11661:
------------------------------------------

I can confirm this behavior, and it's caused by the following lines in {{cassandra-env.sh}}:
{code}
if [ "$JVM_VERSION" \< "1.7" ] ; then
    echo "Cassandra 2.0 and later require Java 7u25 or later."
    exit 1;
fi

if [ "$JVM_VERSION" \< "1.8" ] && [ "$JVM_PATCH_VERSION" \< "25" ] ; then
    echo "Cassandra 2.0 and later require Java 7u25 or later."
    exit 1;
fi
{code}

{code}
$ help test
...
      STRING1 < STRING2
                     True if STRING1 sorts before STRING2 lexicographically.
      STRING1 > STRING2
                     True if STRING1 sorts after STRING2 lexicographically.
...
      arg1 OP arg2   Arithmetic tests.  OP is one of -eq, -ne,
                     -lt, -le, -gt, or -ge.
...
{code}

At the very least, that {{[ "$JVM_PATCH_VERSION" \< "25" ]}} should be replaced by {{[
"$JVM_PATCH_VERSION" -lt "25" ]}}, but the {{$JVM_VERSION}} comparison should also be split
out into major/minor and compared separately via {{-lt}} as well.

> Cassandra 2.0 and later require Java 7u25 or later - jdk 101
> ------------------------------------------------------------
>
>                 Key: CASSANDRA-11661
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-11661
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Testing
>         Environment: Cassandra Server 2.1.5 and Java jdk1.7.0_101-b14
>            Reporter: William Boutin
>            Priority: Critical
>             Fix For: 2.1.x
>
>
> We have been running the cassandr server version 2.1.5. Friday, we applied the latest
java patch, Java(TM) SE Runtime Environment (build 1.7.0_101-b14). Cassandra cannot start
with this patch. The cassandra log states:  Cassandra 2.0 and later require Java 7u25 or later.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message