cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paulo Motta (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-11522) batch_size_fail_threshold_in_kb shouldn't only apply to batch
Date Fri, 15 Apr 2016 13:20:25 GMT


Paulo Motta commented on CASSANDRA-11522:

>From my understanding the main concern here was to make the behavior of {{batch_size_fail_threshold_in_kb}}
consistent between single batch inserts and ordinary inserts, but this was already fixed on
CASSANDRA-10876, but Sylvain will probably be able to clarify best.

We already have {{max_mutation_size_kb}} with a hard limit for mutation size, so IMO we shouldn't
include another artificial limit or warning given it would be hard to define a soft limit
(since it can vary with hardware and load) so it could potentially confuse more than help
(while for batches, a few kilobytes of multi-partition batches can already be catastrophic
so that's why the warn and fail threshold are important in that case).

> batch_size_fail_threshold_in_kb shouldn't only apply to batch
> -------------------------------------------------------------
>                 Key: CASSANDRA-11522
>                 URL:
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Sylvain Lebresne
>            Assignee: Giampaolo
>            Priority: Minor
>              Labels: lhf
> I can buy that C* is not good at dealing with large (in bytes) inserts and that it makes
sense to provide a user configurable protection against inserts larger than a certain size,
but it doesn't make sense to limit this to batches. It's absolutely possible to insert a single
very large row and internally a batch with a single statement is exactly the same than a single
similar insert, so rejecting the former and not the later is confusing and well, wrong.
> Note that I get that batches are more likely to get big and that's where the protection
is most often useful, but limiting the option to batch is still less useful (it's a hole in
the protection) and it's going to confuse users in thinking that batches to a single partition
are different from single inserts.
> Of course that also mean that we should rename that option to {{write_size_fail_threshold_in_kb}}.
Which means we probably want to add this new option and just deprecate {{batch_size_fail_threshold_in_kb}}
for now (with removal in 4.0).

This message was sent by Atlassian JIRA

View raw message