cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksey Yeschenko (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-11490) Cannot upgrade from 2.2.5 to 3.0.4
Date Mon, 04 Apr 2016 17:38:25 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-11490?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15224587#comment-15224587
] 

Aleksey Yeschenko commented on CASSANDRA-11490:
-----------------------------------------------

In case you haven't: 2.1 is supposed to be a mandatory step from 2.0 to 2.2. I'm surprised
it actually worked out at all, if you've done that.

The only thing you can do in this case is to trigger caching value rewrite in 2.2, by altering
each table in some way, nominally.

Think {{ALTER TABLE <table> WITH gc_grace_seconds = <previous gc grace seconds value>}}.

> Cannot upgrade from 2.2.5 to 3.0.4
> ----------------------------------
>
>                 Key: CASSANDRA-11490
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-11490
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Joshua Knarr
>            Assignee: Aleksey Yeschenko
>            Priority: Minor
>
> {code}
> INFO  [main] 2016-04-04 11:57:31,181 SystemKeyspace.java:1284 - Detected version upgrade
from 2.2.5 to 3.0.4, snapshotting system keyspace
> ERROR [main] 2016-04-04 11:57:31,650 CassandraDaemon.java:692 - Exception encountered
during startup
> java.lang.RuntimeException: org.codehaus.jackson.JsonParseException: Unexpected character
('K' (code 75)): expected a valid value (number, String, array, object, 'true', 'false' or
'null')
>  at [Source: java.io.StringReader@3c74247d; line: 1, column: 2]
> 	at org.apache.cassandra.utils.FBUtilities.fromJsonMap(FBUtilities.java:561) ~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.decodeTableParams(LegacySchemaMigrator.java:381)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.decodeTableMetadata(LegacySchemaMigrator.java:363)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.readTableMetadata(LegacySchemaMigrator.java:273)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.readTable(LegacySchemaMigrator.java:244)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.lambda$readTables$233(LegacySchemaMigrator.java:237)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at java.util.ArrayList.forEach(ArrayList.java:1249) ~[na:1.8.0_77]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.readTables(LegacySchemaMigrator.java:237)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.readKeyspace(LegacySchemaMigrator.java:186)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.lambda$readSchema$230(LegacySchemaMigrator.java:177)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at java.util.ArrayList.forEach(ArrayList.java:1249) ~[na:1.8.0_77]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.readSchema(LegacySchemaMigrator.java:177)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.schema.LegacySchemaMigrator.migrate(LegacySchemaMigrator.java:77)
~[apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.service.CassandraDaemon.setup(CassandraDaemon.java:223) [apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.service.CassandraDaemon.activate(CassandraDaemon.java:551) [apache-cassandra-3.0.4.jar:3.0.4]
> 	at org.apache.cassandra.service.CassandraDaemon.main(CassandraDaemon.java:679) [apache-cassandra-3.0.4.jar:3.0.4]
> Caused by: org.codehaus.jackson.JsonParseException: Unexpected character ('K' (code 75)):
expected a valid value (number, String, array, object, 'true', 'false' or 'null')
>  at [Source: java.io.StringReader@3c74247d; line: 1, column: 2]
> 	at org.codehaus.jackson.JsonParser._constructError(JsonParser.java:1432) ~[jackson-core-asl-1.9.2.jar:1.9.2]
> 	at org.codehaus.jackson.impl.JsonParserMinimalBase._reportError(JsonParserMinimalBase.java:385)
~[jackson-core-asl-1.9.2.jar:1.9.2]
> 	at org.codehaus.jackson.impl.JsonParserMinimalBase._reportUnexpectedChar(JsonParserMinimalBase.java:306)
~[jackson-core-asl-1.9.2.jar:1.9.2]
> 	at org.codehaus.jackson.impl.ReaderBasedParser._handleUnexpectedValue(ReaderBasedParser.java:1192)
~[jackson-core-asl-1.9.2.jar:1.9.2]
> 	at org.codehaus.jackson.impl.ReaderBasedParser.nextToken(ReaderBasedParser.java:479)
~[jackson-core-asl-1.9.2.jar:1.9.2]
> 	at org.codehaus.jackson.map.ObjectMapper._initForReading(ObjectMapper.java:2761) ~[jackson-mapper-asl-1.9.2.jar:1.9.2]
> 	at org.codehaus.jackson.map.ObjectMapper._readMapAndClose(ObjectMapper.java:2709) ~[jackson-mapper-asl-1.9.2.jar:1.9.2]
> 	at org.codehaus.jackson.map.ObjectMapper.readValue(ObjectMapper.java:1854) ~[jackson-mapper-asl-1.9.2.jar:1.9.2]
> 	at org.apache.cassandra.utils.FBUtilities.fromJsonMap(FBUtilities.java:557) ~[apache-cassandra-3.0.4.jar:3.0.4]
> 	... 15 common frames omitted
> {code}
> What do? This is an existing 2.2.5 installation I am attempting to upgrade to 3.0.4 -
this happens consistently. Tips? Tricks?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message