cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Branimir Lambov (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-11213) Improve ClusteringPrefix hierarchy
Date Wed, 06 Apr 2016 10:55:25 GMT


Branimir Lambov commented on CASSANDRA-11213:

Squashed, rebased, and updated version here:

Updated the docs and changed the common ancestor to {{ClusteringBoundOrBoundary}}. I was wondering
if {{ClusteringThreshold}} wouldn't be a better name, let me know or feel free to change it
when committing if you prefer that.

> Improve ClusteringPrefix hierarchy
> ----------------------------------
>                 Key: CASSANDRA-11213
>                 URL:
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Sylvain Lebresne
>            Assignee: Branimir Lambov
>             Fix For: 3.x
> As noted by [~blambov] on CASSANDRA-11158, having {{RangeTombstone.Bound}} be a subclass
of {{Slice.Bound}} is somewhat inconsistent. I'd argue in fact that conceptually neither should
really be a subclass of the other as none is a special case of the other and they are use
in strictly non-overlapping places ({{Slice.Bound}} is for slices which are used for selecting
data while {{RangeTombstone.Bound}} is for range tombstone which actually represent some type
of data).
> We should figure out a cleaner hierarchy of this, which probably mean slightly changing
the {{ClusteringPrefix}} hierarchy.

This message was sent by Atlassian JIRA

View raw message