cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Ellis (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-11067) Improve SASI syntax
Date Mon, 25 Jan 2016 16:13:39 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-11067?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Ellis updated CASSANDRA-11067:
---------------------------------------
    Description: 
I think everyone agrees that a LIKE operator would be ideal, but that's probably not in scope
for an initial 3.4 release.

Still, I'm uncomfortable with the initial approach of overloading = to mean "satisfies index
expression."  The problem is that it will be very difficult to back out of this behavior once
people are using it.

I propose adding a new operator in the interim instead.  Call it MATCHES, maybe.  With the
exact same behavior that SASI currently exposes, just with a separate operator rather than
being rolled into =.

  was:
I think everyone agrees that a LIKE operator would be ideal, but that's probably not in scope
for an initial 3.4 release.

Still, I'm uncomfortable with the initial approach of overloading = to mean "satisfies index
expression."  The problem is that it will be very difficult to back out of this behavior once
people are using it.

I propose adding a new operator in the interim instead.  Call it SLIKE, maybe.  With the exact
same behavior that SASI currently exposes, just with a separate operator rather than being
rolled into =.


> Improve SASI syntax
> -------------------
>
>                 Key: CASSANDRA-11067
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-11067
>             Project: Cassandra
>          Issue Type: Task
>          Components: CQL
>            Reporter: Jonathan Ellis
>            Assignee: Sam Tunnicliffe
>
> I think everyone agrees that a LIKE operator would be ideal, but that's probably not
in scope for an initial 3.4 release.
> Still, I'm uncomfortable with the initial approach of overloading = to mean "satisfies
index expression."  The problem is that it will be very difficult to back out of this behavior
once people are using it.
> I propose adding a new operator in the interim instead.  Call it MATCHES, maybe.  With
the exact same behavior that SASI currently exposes, just with a separate operator rather
than being rolled into =.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message