cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sylvain Lebresne (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-10922) Inconsistent query results
Date Fri, 15 Jan 2016 14:59:40 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-10922?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15101873#comment-15101873
] 

Sylvain Lebresne commented on CASSANDRA-10922:
----------------------------------------------

This certainly look wrong, but I'm not sure how much we can move forward without more information.
If you have some idea of how to reproduce that would obviously be very useful. Otherwise,
have you tried running scrub just in case? Maybe also tracing the query to see if it provides
any useful information. Having an idea of the schema on that table might also be helpful.

> Inconsistent query results
> --------------------------
>
>                 Key: CASSANDRA-10922
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-10922
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Maxim Podkolzine
>            Priority: Critical
>
> I have a DB created with Cassandra 2.2.3. And currently I'm running it by Cassandra 3.0.2.
> The value of a particular cell is returned depending on the query I run (in cqlsh):
> - returned when iterate all columns, i.e.
> SELECT value FROM "3xupsource".Content WHERE databaseid=0x21120000 LIMIT 2
> (I can see the columns 0x00000000 and 0x01000000 there, the values seem correct)
> - not returned when I specify a particular column
> SELECT value FROM "3xupsource".Content WHERE databaseid=0x21120000 AND columnid=0x01000000
> Other queries like SELECT value FROM "3xupsource".Content WHERE databaseid=0x21120000
AND columnid=0x00000000 work consistently.
> There is nothing in Cassandra error log, so it does not look like a corruption.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message