cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Stupp (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CASSANDRA-10931) CassandraVersion complains about 3.x version strings
Date Wed, 23 Dec 2015 17:32:46 GMT
Robert Stupp created CASSANDRA-10931:
----------------------------------------

             Summary: CassandraVersion complains about 3.x version strings
                 Key: CASSANDRA-10931
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-10931
             Project: Cassandra
          Issue Type: Bug
            Reporter: Robert Stupp


The utest {{SystemKeyspaceTest.snapshotSystemKeyspaceIfUpgrading}} fails with {{java.lang.IllegalArgumentException:
Invalid version value: 3.2}} (e.g. [here|http://cassci.datastax.com/view/trunk/job/trunk_testall/629/testReport/org.apache.cassandra.db/SystemKeyspaceTest/snapshotSystemKeyspaceIfUpgrading/]).

The question is just:
# change the regex pattern in {{CassandraVersion}} and silently assume {{.0}} as the patch
version or
# go with {{x.y.0}} version strings instead of {{x.y}}




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message