cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ble...@apache.org
Subject [3/4] cassandra git commit: Add a check to cqlsh to require Python-2.7
Date Fri, 23 Oct 2015 07:44:40 GMT
Add a check to cqlsh to require Python-2.7

patch by Benjamin Lerer; reviewed by Stefania Alborghetti for CASSANDRA-10561


Project: http://git-wip-us.apache.org/repos/asf/cassandra/repo
Commit: http://git-wip-us.apache.org/repos/asf/cassandra/commit/a5053fd9
Tree: http://git-wip-us.apache.org/repos/asf/cassandra/tree/a5053fd9
Diff: http://git-wip-us.apache.org/repos/asf/cassandra/diff/a5053fd9

Branch: refs/heads/cassandra-3.0
Commit: a5053fd9447ae1d41e600418bf9fcb158398e8d0
Parents: bbaa963
Author: blerer <benjamin.lerer@datastax.com>
Authored: Fri Oct 23 09:39:31 2015 +0200
Committer: blerer <benjamin.lerer@datastax.com>
Committed: Fri Oct 23 09:39:31 2015 +0200

----------------------------------------------------------------------
 bin/cqlsh.py | 3 +++
 1 file changed, 3 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cassandra/blob/a5053fd9/bin/cqlsh.py
----------------------------------------------------------------------
diff --git a/bin/cqlsh.py b/bin/cqlsh.py
index a15fb02..7f2d39b 100644
--- a/bin/cqlsh.py
+++ b/bin/cqlsh.py
@@ -51,6 +51,9 @@ from glob import glob
 from StringIO import StringIO
 from uuid import UUID
 
+if sys.version_info[0] != 2 or sys.version_info[1] != 7:
+    sys.exit("\nCQL Shell supports only Python 2.7\n")
+
 description = "CQL Shell for Apache Cassandra"
 version = "5.0.1"
 


Mime
View raw message