cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vovodroid (JIRA)" <>
Subject [jira] [Updated] (CASSANDRA-10305) NullPointerException on database migration/load
Date Sat, 12 Sep 2015 06:02:45 GMT


Vovodroid updated CASSANDRA-10305:
    Attachment:     (was: crash.log)

> NullPointerException on database migration/load
> -----------------------------------------------
>                 Key: CASSANDRA-10305
>                 URL:
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>         Environment: CentOS 7.1/x64
>            Reporter: Vovodroid
>            Priority: Critical
> I run some tests in C* 2.2.1 with script that launches cqlsh and feeds commands to its
stdin and gets results from stdout. Several cqlsh instances are involved in parallel.
> Test includes creating and dropping the same keyspace several times.
> I need to add timeouts between feeding command and reading results, otherwise tests fail.
If this timeout too small Cassandra sometimes fails with NullPointerException (see crash.log).

> But what is worst, that after that Cassandra can not be started at all and fail with
the same error (see startup.log).
> What happens is that inside of *row.getString("type")* called from
> {code}
> LegacySchemaTables.createColumnFromColumnRow
> ..........................
> ColumnDefinition.Kind kind = deserializeKind(row.getString("type"));{code}
> *data.get(column)* returns null for table *excelsiour_amd__amd__.users*.
> Data causing this issue is in (no commit logs due to their size, but I can give
them if necessary).
> Just open zip in Cassandra folder (or where data is located in specific environment)
and start C*.

This message was sent by Atlassian JIRA

View raw message