cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "navithejesh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-10255) AttributeError: 'module' object has no attribute 'compress'
Date Fri, 04 Sep 2015 06:25:45 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-10255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14730376#comment-14730376
] 

navithejesh commented on CASSANDRA-10255:
-----------------------------------------

Hi Tyler,

Firstly i would like to thank you for reply......


In our set-up there are two systems A and B
--> Initially, A was the single node previously, having data of 167.44GB and recently upgraded
from Apache Cassandra 2.0.11 to 2.1.8
--> B is the new node with Apache Cassandra 2.1.8
--> we made two machines up and created cluster between A and B. All the data is shared
and when i run ./nodetool status in node A it is showing A is having 167.44 GB of data and
node B is showing 553.77GB.
--> In node A we installed lz4 and python-snappy before loading data and in node B we didn't.
--> when i run ./cqlsh on node B, am not able to run it and its throwing an error like
AttributeError: 'module' object has no attribute 'compress' 
--> Later i understood that i haven't installed lz4 and python-snappy in node B.
--> Now i installed and lz4 and python-snappy libraries and started Cassandra service in
node B.But still it shows the same error.
--> And also we find differences in data sizes in both, the node A (167.44GB which is seed
node) and node B (553.77GB ) we don't understand the reason behind this.


> AttributeError: 'module' object has no attribute 'compress' 
> ------------------------------------------------------------
>
>                 Key: CASSANDRA-10255
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-10255
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Config, Packaging
>         Environment: Linux fedora 21
>            Reporter: navithejesh
>              Labels: cqlsh
>             Fix For: 2.1.x
>
>         Attachments: error.jpeg
>
>
> Hi Recently i have upgrade my server from cassandra version 2.0.11 to 2.1.8 using tarball
installation.And i have added one node to existing culster with the same version of 2.1.8.
All the configuration settings are done but am not able to run cqlsh from bin directory.and
this is the error
> AttributeError: 'module' object has no attribute 'compress'
> {code}
> ./cqlsh
> Traceback (most recent call last):
>  File "./cqlsh", line 111, in <module>
>     from cassandra.cluster import Cluster, PagedResult
> File "/home/cassandra/apache-cassandra-2.1.8/bin/../lib/cassandra-driver-internal-only-2.6.0c2.post.zip/cassandra-driver-2.6.0c2.post/cassandra/cluster.py",
line 49, in <module>
>  File "/home/cassandra/apache-cassandra-2.1.8/bin/../lib/cassandra-driver-internal-only-2.6.0c2.post.zip/cassandra-driver-2.6.0c2.post/cassandra/connection.py",
line 88, in <module>
> AttributeError: 'module' object has no attribute 'compress'
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message