cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Lerer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-9585) Make "truncate table X" an alias for "truncate X"
Date Wed, 09 Sep 2015 18:53:46 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-9585?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14737399#comment-14737399
] 

Benjamin Lerer commented on CASSANDRA-9585:
-------------------------------------------

Thanks,
I remembered that one ... when I had 60+ dtests failing on CI ;-)

> Make "truncate table X" an alias for "truncate X"
> -------------------------------------------------
>
>                 Key: CASSANDRA-9585
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9585
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: J.B. Langston
>            Assignee: Benjamin Lerer
>            Priority: Trivial
>             Fix For: 2.1.x
>
>         Attachments: 9585-2.1-V2.txt, 9585-2.1.txt
>
>
> CQL syntax is inconsistent: it's "drop table X" but "truncate X". It used to trip me
up all the time until I wrapped my brain around this inconsistency and it still triggers a
tiny bout of OCD every time I type it.  I realize it's too late to change it,  but why not
have both? "truncate table X" is also consistent with the syntax in SQL.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message