cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Lerer (JIRA)" <>
Subject [jira] [Updated] (CASSANDRA-9585) Make "truncate table X" an alias for "truncate X"
Date Wed, 09 Sep 2015 09:50:46 GMT


Benjamin Lerer updated CASSANDRA-9585:
    Attachment: 9585-2.1-V2.txt

Thanks for the review.

The unit test was already testing both the {{TRUNCATE}} and {{TRUNCATE TABLE}} syntax.

The patch fix the cqlsh and the documentation.

In this case, I think that it is ok to change the syntax as it is fully backward compatible.

> Make "truncate table X" an alias for "truncate X"
> -------------------------------------------------
>                 Key: CASSANDRA-9585
>                 URL:
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: J.B. Langston
>            Assignee: Benjamin Lerer
>            Priority: Trivial
>             Fix For: 2.1.x
>         Attachments: 9585-2.1-V2.txt, 9585-2.1.txt
> CQL syntax is inconsistent: it's "drop table X" but "truncate X". It used to trip me
up all the time until I wrapped my brain around this inconsistency and it still triggers a
tiny bout of OCD every time I type it.  I realize it's too late to change it,  but why not
have both? "truncate table X" is also consistent with the syntax in SQL.

This message was sent by Atlassian JIRA

View raw message