cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksey Yeschenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-9997) Removing cold_reads_to_omit in 2.2 is not backwards compatible with 2.1
Date Thu, 06 Aug 2015 15:04:05 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-9997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Aleksey Yeschenko updated CASSANDRA-9997:
-----------------------------------------
         Priority: Blocker  (was: Major)
    Fix Version/s: 2.2.1

> Removing cold_reads_to_omit in 2.2 is not backwards compatible with 2.1
> -----------------------------------------------------------------------
>
>                 Key: CASSANDRA-9997
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9997
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Tommy Stendahl
>            Priority: Blocker
>             Fix For: 2.2.1
>
>
> Shouldn’t 2.2 be backwards compatible with 2.1? 
> The removal of the cold_reads_to_omit parameter in SizeTieredCompactionStrategy breaks
backwards compatibility, wouldn't it be better to keep the same behaviour as in later 2.1
versions, the parameter is there but doesn’t do anything. The cold_reads_to_omit parameter
should be removed in 3.0.
> This could be fixed by applying the patch in CASSANDRA-9203 on the 2.2 branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message