cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Lerer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-9913) Select * is only returning the first page of data on trunk
Date Mon, 10 Aug 2015 13:02:46 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-9913?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14680064#comment-14680064
] 

Benjamin Lerer commented on CASSANDRA-9913:
-------------------------------------------

Thanks for the review.

{quote}Is there absolutely no way to cover these two cases with unit tests and are static
compact tables the only ones with "fake" clustering columns?{quote}

I tried to add Unit tests for the problem. The problem that I faced was that the path was
not the same than for the client paging. Due to that the effect of the problem was different.
I discussed with Aleksey offline and we decided to rely only on the DTests for this issue.

Based on my understanding of compact tables, I think that we should only have this problem
for static compact tables.

> Select * is only returning the first page of data on trunk
> ----------------------------------------------------------
>
>                 Key: CASSANDRA-9913
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9913
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Philip Thompson
>            Assignee: Benjamin Lerer
>             Fix For: 3.0 beta 1
>
>         Attachments: 9913.txt
>
>
> While doing some testing on the validation harness, I have run into a pretty trivially
reproducible problem.
> {code}
> ccm create test -v git:trunk -n 1 -s
> ccm node1 stress write n=2M
> ccm node1 cqlsh
> {code}
> {code}
> Use keyspace1;
> Select * From standard1; (100 rows)
> Select count(*) from standard1; (300 rows)
> {code}
> Despite two million rows being written, I have found that {{select * from standard1}}
only returns one page's worth of data. I have used both the java and the python driver to
test this. I have also found that {{select count(*) from standard1}} gives a multiple of one
page's worth of data, that appears to correspond to page size * RF.
> I have already tried with the patch for CASSANDRA-9775, and that did not resolve this
issue.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message