cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zachary St Lawrence (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CASSANDRA-9451) Startup message response for unsupported protocol versions is incorrect
Date Tue, 21 Jul 2015 19:28:04 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-9451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14635669#comment-14635669
] 

Zachary St Lawrence edited comment on CASSANDRA-9451 at 7/21/15 7:27 PM:
-------------------------------------------------------------------------

There may be a regression.  Testing with 2.1.7 and 2.1.8 I get the following:

{code}> cqlsh_to_2_1_server.sh
[cqlsh 5.0.1 | Cassandra 2.1.4 | CQL spec 3.2.0 | Native protocol v3]
Use HELP for help.{code}

When I upgrade to 2.2.0 client I immediately get the problem occurring again.

{code}> sudo apt-get install cassandra=2.2.0
Unpacking cassandra (2.2.0) over (2.1.8) ...

> cqlsh_to_2_1_server.sh
Connection error: ('Unable to connect to any servers', {'sqa-cassandra01': ConnectionException(u'Did
not get expected SupportedMessage response; instead, got: <ErrorMessage code=0000 [Server
error] message="io.netty.handler.codec.DecoderException: org.apache.cassandra.transport.ProtocolException:
Invalid or unsupported protocol version: 4">',)}){code}

Edit: simplified example


was (Author: zstlaw):
There may be a regression.  Testing with 2.1.7 and 2.1.8 I get the following:

{quote}> cqlsh_to_2_1_server.sh
[cqlsh 5.0.1 | Cassandra 2.1.4 | CQL spec 3.2.0 | Native protocol v3]
Use HELP for help.{quote}

When I upgrade to 2.2.0 client I immediately get the problem occurring again.

{noformat}sudo apt-get install cassandra=2.2.0
Unpacking cassandra (2.2.0) over (2.1.8) ...
Setting up cassandra (2.2.0) ...
Installing new version of config file /etc/cassandra/cassandra-env.sh ...
Installing new version of config file /etc/cassandra/commitlog_archiving.properties ...
Installing new version of config file /etc/cassandra/logback.xml ...
Installing new version of config file /etc/cassandra/cassandra.yaml ...

> cqlsh_to_2_1_server.sh
Connection error: ('Unable to connect to any servers', {'sqa-cassandra01': ConnectionException(u'Did
not get expected SupportedMessage response; instead, got: <ErrorMessage code=0000 [Server
error] message="io.netty.handler.codec.DecoderException: org.apache.cassandra.transport.ProtocolException:
Invalid or unsupported protocol version: 4">',)}){noformat}


> Startup message response for unsupported protocol versions is incorrect
> -----------------------------------------------------------------------
>
>                 Key: CASSANDRA-9451
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9451
>             Project: Cassandra
>          Issue Type: Bug
>         Environment: OS X 10.9
> Cassandra 2.1.5 
>            Reporter: Jorge Bay
>            Assignee: Tyler Hobbs
>              Labels: client-impacting
>             Fix For: 2.1.6, 2.2.0 rc1
>
>         Attachments: 9451.txt
>
>
> The response to a STARTUP request with protocol v4 on a C* 2.1 host is an error with
an incorrect error code (0). 
> Instead of the error code being "Protocol error" ({{0x000A}}) it has error code 0 and
message (wrapped by netty): 
> {{"io.netty.handler.codec.DecoderException: org.apache.cassandra.transport.ProtocolException:
Invalid or unsupported protocol version: 4"}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message