cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yuki Morishita (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-9448) Metrics should use up to date nomenclature
Date Fri, 10 Jul 2015 18:15:05 GMT


Yuki Morishita commented on CASSANDRA-9448:

[~stefania_alborghetti] Thanks! So it is possible to have both old and new name for metrics.
Even though we cannot mark old ones as {{@Deprecated}} for technical reason, this is enough
for transition.

I created [pull request|] for your branch to use
new names for {{ColumnFamilyStoreMBean}}.
If that looks good, I will commit the change.

> Metrics should use up to date nomenclature
> ------------------------------------------
>                 Key: CASSANDRA-9448
>                 URL:
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>            Reporter: Sam Tunnicliffe
>            Assignee: Stefania
>              Labels: docs-impacting, jmx
>             Fix For: 3.0 beta 1
> There are a number of exposed metrics that currently are named using the old nomenclature
of columnfamily and rows (meaning partitions).
> It would be good to audit all metrics and update any names to match what they actually
represent; we should probably do that in a single sweep to avoid a confusing mixture of old
and new terminology. 
> As we'd need to do this in a major release, I've initially set the fixver for 3.0 beta1.

This message was sent by Atlassian JIRA

View raw message