cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "T Jake Luciani (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8384) Change CREATE TABLE syntax for compression options
Date Thu, 02 Jul 2015 14:21:06 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8384?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14612008#comment-14612008
] 

T Jake Luciani commented on CASSANDRA-8384:
-------------------------------------------

[~iamaleksey] mentioned this ticket to me and specifically the hack from CASSANDRA-7978 is
causing problems.

I think we should move crc_check_chance out of compression options and make it cfs level just
like read_repair_chance, that would fix all the issues and we can remove that code.

> Change CREATE TABLE syntax for compression options
> --------------------------------------------------
>
>                 Key: CASSANDRA-8384
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8384
>             Project: Cassandra
>          Issue Type: Sub-task
>            Reporter: Aleksey Yeschenko
>            Assignee: Benjamin Lerer
>              Labels: doc-impacting, docs
>             Fix For: 3.x
>
>
> Currently, `compression` table options are inconsistent with the likes of it (table `compaction`,
keyspace `replication`).
> I suggest we change it for 3.0, like we did change `caching` syntax for 2.1 (while continuing
to accept the old syntax for a release).
> I recommend the following changes:
> 1. rename `sstable_compression` to `class`, to make it consistent `compression` and `replication`
> 2. rename `chunk_length_kb` to `chunk_length_in_kb`, to match `memtable_flush_period_in_ms`,
or, alternatively, to just `chunk_length`, with `memtable_flush_period_in_ms` renamed to `memtable_flush_period`
- consistent with every other CQL option everywhere else
> 3. add a boolean `enabled` option, to match `compaction`. Currently, the official way
to disable comression is an ugly, ugly hack (see CASSANDRA-8288)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message