cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Lerer (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-8384) Change CREATE TABLE syntax for compression options
Date Mon, 06 Jul 2015 20:05:05 GMT


Benjamin Lerer commented on CASSANDRA-8384:

I had a look, but moving {{crc_check_chance}} out of the compression options is not straight
forward. So, I prefer if we address it in another ticket.

I fixed the review comments and implemented some of the refactoring discussed off line with
The branch is [here|]

> Change CREATE TABLE syntax for compression options
> --------------------------------------------------
>                 Key: CASSANDRA-8384
>                 URL:
>             Project: Cassandra
>          Issue Type: Sub-task
>            Reporter: Aleksey Yeschenko
>            Assignee: Benjamin Lerer
>              Labels: doc-impacting, docs
>             Fix For: 3.x
> Currently, `compression` table options are inconsistent with the likes of it (table `compaction`,
keyspace `replication`).
> I suggest we change it for 3.0, like we did change `caching` syntax for 2.1 (while continuing
to accept the old syntax for a release).
> I recommend the following changes:
> 1. rename `sstable_compression` to `class`, to make it consistent `compression` and `replication`
> 2. rename `chunk_length_kb` to `chunk_length_in_kb`, to match `memtable_flush_period_in_ms`,
or, alternatively, to just `chunk_length`, with `memtable_flush_period_in_ms` renamed to `memtable_flush_period`
- consistent with every other CQL option everywhere else
> 3. add a boolean `enabled` option, to match `compaction`. Currently, the official way
to disable comression is an ugly, ugly hack (see CASSANDRA-8288)

This message was sent by Atlassian JIRA

View raw message