cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Williams (JIRA)" <>
Subject [jira] [Updated] (CASSANDRA-9585) Make "truncate table X" an alias for "truncate X"
Date Thu, 11 Jun 2015 20:14:01 GMT


Brandon Williams updated CASSANDRA-9585:
    Fix Version/s: 2.1.x

> Make "truncate table X" an alias for "truncate X"
> -------------------------------------------------
>                 Key: CASSANDRA-9585
>                 URL:
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: J.B. Langston
>            Priority: Trivial
>             Fix For: 2.1.x
> CQL syntax is inconsistent: it's "drop table X" but "truncate X". It used to trip me
up all the time until I wrapped my brain around this inconsistency and it still triggers a
tiny bout of OCD every time I type it.  I realize it's too late to change it,  but why not
have both? "truncate table X" is also consistent with the syntax in SQL.

This message was sent by Atlassian JIRA

View raw message