cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip Thompson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-9410) Fix? jar conflict with ecj
Date Mon, 18 May 2015 16:18:00 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-9410?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14548225#comment-14548225
] 

Philip Thompson commented on CASSANDRA-9410:
--------------------------------------------

I had an issue using IntellIiJ on trunk because of this issue. The patch fixed my problem.

> Fix? jar conflict with ecj
> --------------------------
>
>                 Key: CASSANDRA-9410
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9410
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core, Hadoop
>            Reporter: Dave Brosius
>            Assignee: Dave Brosius
>            Priority: Trivial
>             Fix For: 2.2 beta 1
>
>         Attachments: ecj_conflict.txt
>
>
> hadoop-core pulls in core-3.1.1.jar which is an older version of ecj-4.4.2 which is now
used directly for UDFs. Thus there are package/class conflicts between the two, when both
are present on the classpath (at present)
> Made changes to remove the older core-3.1.1 dependency, and now the hadoop code relies
on ecj-4.4.2. Code compiles, but not sure what needs to be done to validate the hadoop still
works properly now only relying on ecj-4.4.2



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message