cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Terry Moschou (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CASSANDRA-8820) Broken package dependency in Debian repository
Date Thu, 02 Apr 2015 03:27:53 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8820?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14392058#comment-14392058
] 

Terry Moschou edited comment on CASSANDRA-8820 at 4/2/15 3:27 AM:
------------------------------------------------------------------

This issue has popped up again with the release of 2.1.4.

cassandra_2.1.4 has been pushed to the debian repo, but
cassandra-tools remains at version 2.1.3

Edit:
```
$ apt-cache policy cassandra cassandra-tools
cassandra:
  Installed: 2.1.4
  Candidate: 2.1.4
  Version table:
 *** 2.1.4 0
        500 http://www.apache.org/dist/cassandra/debian/ 21x/main amd64 Packages
        100 /var/lib/dpkg/status
cassandra-tools:
  Installed: (none)
  Candidate: 2.1.3
  Version table:
     2.1.3 0
        500 http://www.apache.org/dist/cassandra/debian/ 21x/main amd64 Packages
```


was (Author: tmoschou):
This issue has popped up again with the release of 2.1.4.

cassandra_2.1.4 has been pushed to the debian repo, but
cassandra-tools remains at version 2.1.3

> Broken package dependency in Debian repository
> ----------------------------------------------
>
>                 Key: CASSANDRA-8820
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8820
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Packaging
>         Environment: Ubuntu 14.04 LTS amd64
>            Reporter: Terry Moschou
>            Assignee: T Jake Luciani
>
> The Apache Debian package repository currently has unmet dependencies.
> Configured repos:
> deb http://www.apache.org/dist/cassandra/debian 21x main
> deb-src http://www.apache.org/dist/cassandra/debian 21x main
> Problem file:
> cassandra/dists/21x/main/binary-amd64/Packages
> $ sudo apt-get update && sudo apt-get install cassandra-tools
> ...(omitted)
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>  cassandra-tools : Depends: cassandra (= 2.1.2) but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message