cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Branimir Lambov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8988) Optimise IntervalTree
Date Fri, 20 Mar 2015 14:22:38 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8988?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14371340#comment-14371340
] 

Branimir Lambov commented on CASSANDRA-8988:
--------------------------------------------

+1 again, with one last nit: Could we give things in AsymmetricOrdering slightly better names?
'compare2' and 'find2' aren't very descriptive. The former could be just 'compare', letting
the right one be picked by the choice of arguments, and the latter should probably be 'binarySearch'.
Same goes for 'inclusivei', 'returni', as well as 'search' and 'find' in find2.

> Optimise IntervalTree
> ---------------------
>
>                 Key: CASSANDRA-8988
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8988
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Benedict
>            Assignee: Benedict
>            Priority: Minor
>             Fix For: 3.0
>
>         Attachments: 8988.txt
>
>
> We perform a lot of unnecessary comparisons in IntervalTree.IntervalNode.searchInternal.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message