cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sylvain Lebresne (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8553) Add a key-value payload for third party usage
Date Mon, 16 Mar 2015 12:00:48 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8553?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14363113#comment-14363113
] 

Sylvain Lebresne commented on CASSANDRA-8553:
---------------------------------------------

A few small remarks:
* I'd rename every of instance "payload", which is too generic, into "customPayload". We want
to make it extra clear, including in the code, that it's a totally custom thing. On that front,
I'd make it clearer in the spec that this payload is ignored by default.
* I'd add a {{QueryProcessor.process}} (and maybe all the other {{prepared}}, {{processPrepared}}
and {{processBatch}}) variant without payload to avoid having to pass {{null}} in a bunch
of places. Again, we don't want this to leak in the code more than this have to, and no internal
usage will ever pass a custom payload by definition.
* We should verify the protocol version when receiving/sending messages with a custom payload,
and complain if it's inappropriate.
* Injecting the query handler statically in {{MessagePayloadTest}} won't work if all tests
are executed in the same JVM (which at least the {{ant cql-test}} target does, but it's fragile
regardless). But it also bother me to make {{ClientState.cqlQueryHandler}} non final in general,
so I'd suggest setting the field through reflexion in {{MessagePayloadTest}} and resetting
it back afterwards. It's ugly, but at least it contains the ugliness to that test. And it'll
remove the ugliness around extending CQLTester.
* Please add brackets to the {{for}} loop in CQLTester static block.


> Add a key-value payload for third party usage
> ---------------------------------------------
>
>                 Key: CASSANDRA-8553
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8553
>             Project: Cassandra
>          Issue Type: Sub-task
>            Reporter: Sergio Bossa
>            Assignee: Robert Stupp
>              Labels: client-impacting, protocolv4
>             Fix For: 3.0
>
>         Attachments: 8553.txt
>
>
> An useful improvement would be to include a generic key-value payload, so that developers
implementing a custom {{QueryHandler}} could leverage that to move custom data back and forth.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message