cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luke Gordon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8637) Update LZ4 library to 1.3.0
Date Sat, 17 Jan 2015 07:13:34 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8637?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14281244#comment-14281244
] 

Luke Gordon commented on CASSANDRA-8637:
----------------------------------------

I can understand wanting to mitigate risk, but this doesn't seem to be uncharacteristic or
unprecedented in Apache Cassandra's history.  The LZ4 version bump is on a minor release,
but in past minor version bumps to Apache Cassandra, they've upgrade full versions of 3rd
party libraries.  For example:
Apache Cassandra 2.0.9
Guava - 15.0
Netty - 3.6.6.Final

Apache Cassandra 2.1.2
Guava - 16.0
Netty - 4.0.23.Final
commons-math3 (this was added and not in 2.0.9)

I think the bump from 1.2.0 to 1.3.0 is pretty low risk.  Asking for people to do a full major
bump for this 1 library's minor release seems a bit extreme.

> Update LZ4 library to 1.3.0
> ---------------------------
>
>                 Key: CASSANDRA-8637
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8637
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Luke Gordon
>            Priority: Minor
>             Fix For: 2.1.3
>
>
> This is a follow up of https://issues.apache.org/jira/browse/CASSANDRA-7573.  A fix for
https://github.com/jpountz/lz4-java/pull/46 has been released in LZ4 1.3.0.  Apache Cassandra
is still using 1.2.0.  Can this library be upgraded to correct the issue outlined in 7573?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message