cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "T Jake Luciani (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-7491) Incorrect thrift-server dependency in 2.0 poms
Date Tue, 20 Jan 2015 17:10:00 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-7491?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

T Jake Luciani updated CASSANDRA-7491:
--------------------------------------
    Fix Version/s:     (was: 2.0.12)
                   2.0.13

> Incorrect thrift-server dependency in 2.0 poms
> ----------------------------------------------
>
>                 Key: CASSANDRA-7491
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-7491
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Packaging
>            Reporter: Sam Tunnicliffe
>             Fix For: 2.0.13
>
>
> On the 2.0 branch we recently replaced thrift-server-0.3.3.jar with thrift-server-internal-only-0.3.3.jar
(commit says CASSANDRA-6545, but I don't think that's right), but didn't update the generated
pom that gets deployed to mvn central. The upshot is that the poms on maven central for 2.0.8
& 2.0.9 specify their dependencies incorrectly. So any project pulling in those versions
of cassandra-all as a dependency will incorrectly include the old jar.
> However, on 2.1 & trunk the internal-only jar was subsequently replaced by thrift-server-0.3.5.jar
(CASSANDRA-6285), which *is* available in mvn central. build.xml has also been updated correctly
on these branches.
> [~xedin], is there any reason for not switching 2.0 to thrift-server-0.3.5.jar ?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message