cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcus Eriksson (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-8316) "Did not get positive replies from all endpoints" error on incremental repair
Date Fri, 12 Dec 2014 15:05:18 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-8316?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Marcus Eriksson updated CASSANDRA-8316:
---------------------------------------
    Attachment: 8316-v2.patch

Attaching new patch, found the problem with compacting-marking - we fail marking compacting
if one of the sstables is marked compacted, this makes sure we remove those before retrying
(infinite loop otherwise)

Also adds a try/catch around the switch(..) in RepairMessageVerbHandler, might be a bit much,
but it makes sure we always remove the parent repair session on failures.

With this + the patch in CASSANDRA-8458 i'm able continuously run incremental repairs on a
heavily loaded 6 node cluster.

>  "Did not get positive replies from all endpoints" error on incremental repair
> ------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-8316
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8316
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>         Environment: cassandra 2.1.2
>            Reporter: Loic Lambiel
>            Assignee: Marcus Eriksson
>             Fix For: 2.1.3
>
>         Attachments: 0001-patch.patch, 8316-v2.patch, CassandraDaemon-2014-11-25-2.snapshot.tar.gz,
test.sh
>
>
> Hi,
> I've got an issue with incremental repairs on our production 15 nodes 2.1.2 (new cluster,
not yet loaded, RF=3)
> After having successfully performed an incremental repair (-par -inc) on 3 nodes, I started
receiving "Repair failed with error Did not get positive replies from all endpoints." from
nodetool on all remaining nodes :
> [2014-11-14 09:12:36,488] Starting repair command #3, repairing 108 ranges for keyspace
xxxx (seq=false, full=false)
> [2014-11-14 09:12:47,919] Repair failed with error Did not get positive replies from
all endpoints.
> All the nodes are up and running and the local system log shows that the repair commands
got started and that's it.
> I've also noticed that soon after the repair, several nodes started having more cpu load
indefinitely without any particular reason (no tasks / queries, nothing in the logs). I then
restarted C* on these nodes and retried the repair on several nodes, which were successful
until facing the issue again.
> I tried to repro on our 3 nodes preproduction cluster without success
> It looks like I'm not the only one having this issue: http://www.mail-archive.com/user%40cassandra.apache.org/msg39145.html
> Any idea?
> Thanks
> Loic



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message