cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sylvain Lebresne (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8384) Consider changing CREATE TABLE syntax for compression options in 3.0
Date Thu, 27 Nov 2014 16:23:13 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8384?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14227802#comment-14227802
] 

Sylvain Lebresne commented on CASSANDRA-8384:
---------------------------------------------

I'm good with 1 and 3 (provided we do support the old syntax for at least one version). Regarding
2, I do prefer keeping the unit as part of the name over the alternative. Adding a 'in' feels
a bit nitpicky, but I suppose it's not a huge deal if we've changing the syntax of the overall
option anyway, so +0 from me.

> Consider changing CREATE TABLE syntax for compression options in 3.0
> --------------------------------------------------------------------
>
>                 Key: CASSANDRA-8384
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8384
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Aleksey Yeschenko
>            Assignee: Aleksey Yeschenko
>             Fix For: 3.0
>
>
> Currently, `compression` table options are inconsistent with the likes of it (table `compaction`,
keyspace `replication`).
> I suggest we change it for 3.0, like we did change `caching` syntax for 2.1 (while continuing
to accept the old syntax for a release).
> I recommend the following changes:
> 1. rename `sstable_compression` to `class`, to make it consistent `compression` and `replication`
> 2. rename `chunk_length_kb` to `chunk_length_in_kb`, to match `memtable_flush_period_in_ms`,
or, alternatively, to just `chunk_length`, with `memtable_flush_period_in_ms` renamed to `memtable_flush_period`
- consistent with every other CQL option everywhere else
> 3. add a boolean `enabled` option, to match `compaction`. Currently, the official way
to disable comression is an ugly, ugly hack (see CASSANDRA-8288)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message