cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "T Jake Luciani (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8168) Require Java 8
Date Mon, 24 Nov 2014 15:43:14 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8168?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14223062#comment-14223062
] 

T Jake Luciani commented on CASSANDRA-8168:
-------------------------------------------

bq.  And that CompletableFuture gives us something that guava's ListenableFuture don't give
us?

Agreed.  I do think lambas help make this code more maintainable but not required.  


One thing I've learned is java 8 should give us some performance boost due to improvements
in CAS contention improvements.  We use these types extensively on the hot path
http://ashkrit.blogspot.com/2014/02/atomicinteger-java-7-vs-java-8.html



> Require Java 8
> --------------
>
>                 Key: CASSANDRA-8168
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8168
>             Project: Cassandra
>          Issue Type: Task
>            Reporter: T Jake Luciani
>            Assignee: T Jake Luciani
>             Fix For: 3.0
>
>
> This is to discuss requiring Java 8 for version >= 3.0  
> There are a couple big reasons for this.
> * Better support for complex async work  e.g (CASSANDRA-5239)    http://docs.oracle.com/javase/8/docs/api/java/util/concurrent/CompletableFuture.html
> * Use Nashorn for Javascript UDFs CASSANDRA-7395



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message