cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew O'Riordan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8023) DESCRIBE KEYSPACES / KEYSPACE no longer works with Cassandra 2.1 and cqlsh
Date Thu, 02 Oct 2014 01:25:33 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8023?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14155959#comment-14155959
] 

Matthew O'Riordan commented on CASSANDRA-8023:
----------------------------------------------

Please note that upon further inspection across 6 servers (2 in each region), I see that on
4 of the boxes `DESCRIBE KEYSPACES` returns the keyspaces, and on 2 of the boxes `DESCRIBE
KEYSPACES` returns <empty>.  It seems that somehow after upgrading to 2.1, the cluster
is somewhat corrupted, and I have found data missing on some of the servers, but not all.

I think this ticket may need to be reassigned because this is probably not a tools issue,
but instead a corrupt data issue that is making the tools play up.  Oddly, even on the servers
that fail the `DESCRIBE KEYSPACES` call, doing a `select * from system.schema_keyspaces` does
return a valid list of keyspaces.

> DESCRIBE KEYSPACES / KEYSPACE no longer works with Cassandra 2.1 and cqlsh
> --------------------------------------------------------------------------
>
>                 Key: CASSANDRA-8023
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8023
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Tools
>         Environment: Ubuntu 14.04, running in a Docker container with Ubuntu 14.04
>            Reporter: Matthew O'Riordan
>              Labels: cqlsh
>             Fix For: 2.1.1
>
>
> Connecting to my Cassandra 2.1 cluster with the new 5.0.1 version of cqlsh, when I run
DESCRIBE KEYSPACES I am told there are no keyspaces.  
> ```
> cqlsh> describe keyspaces
> describe keyspaces
> <empty>
> ```
> Yet if I connect to that same cluster with version 4 of cqlsh it works fine, I can query
the keyspaces, and if I run the query manually `select * from system.schema_keyspaces` I am
given a list of keyspaces.
> `DESCRIBE KEYSPACE` also fails with the new cqlsh tool, yet works with version 4.
> ```
> cqlsh>use mykeyspace;
> cqlsh:mykeyspace> describe keyspace;
> describe keyspace;
> Keyspace 'ably_sandbox_0' not found.
> ```



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message