cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Lerer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-7924) Optimization of Java UDFs
Date Tue, 23 Sep 2014 13:47:33 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-7924?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14144803#comment-14144803
] 

Benjamin Lerer commented on CASSANDRA-7924:
-------------------------------------------

The code of {{JavaSourceUDFFactory}} is much easier to read. Nice work.

A few minor stuff:
* Your large comments are good but they should be in the method javadocs and not in block
comments. That way they will not interfer with the reading of the code but are there when
the reader need to refer to them.
* You sometime chain append and sometimes not. It is a bit disturbing. You should choose one
and be consistent.



> Optimization of Java UDFs
> -------------------------
>
>                 Key: CASSANDRA-7924
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-7924
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Robert Stupp
>            Assignee: Robert Stupp
>              Labels: docs, lhf, udf
>             Fix For: 3.0
>
>         Attachments: 7924.txt, 7924v2.txt
>
>
> Refactor 'java' UDFs to optimize invocation. Goal is to remove reflection code. Implementation
uses javassist to generate an instance of {{Function}} that can be directly used.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message