cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedict (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-6904) commitlog segments may not be archived after restart
Date Mon, 22 Sep 2014 10:30:34 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-6904?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14143076#comment-14143076
] 

Benedict commented on CASSANDRA-6904:
-------------------------------------

bq. if that target file already exists we throw an exception and bail on startup

Good point. Given we now _expect_ this situation, though, we should probably change that behaviour.
But agreed, the naming of the files during restore should have already solved the problem
I was highlighting.

bq. On the native archive, I'd rather we handle any general rework of the archival process
as a separate ticket if nobody objects.

WFM. But "rework" is much too strong a word IMO - we're going to have to support the current
archival option indefinitely, most likely (and really it's low cost to do so, code is tiny)
- we just want to give people a saner option to move to. Which pretty much means offering
a yaml option and making the archive command a function:CLS->Runnable, with the runnable
doing a native copy (and perhaps supporting hard linking, which is slightly trickier, but
still not hard and not a requisite) as well as the current option. So it's small enough I'd
also feel very comfortable including it here.

> commitlog segments may not be archived after restart
> ----------------------------------------------------
>
>                 Key: CASSANDRA-6904
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-6904
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>            Reporter: Jonathan Ellis
>            Assignee: Sam Tunnicliffe
>             Fix For: 2.0.11, 2.1.1
>
>         Attachments: 2.0-6904.txt, 2.1-6904.txt
>
>
> commitlog segments are archived when they are full, so the current active segment will
not be archived on restart (and its contents will not be available for pitr).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message