cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan McGuire (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CASSANDRA-7799) cassandra-env.sh doesn't detect openjdk version numbers
Date Tue, 19 Aug 2014 21:49:21 GMT
Ryan McGuire created CASSANDRA-7799:
---------------------------------------

             Summary: cassandra-env.sh doesn't detect openjdk version numbers
                 Key: CASSANDRA-7799
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-7799
             Project: Cassandra
          Issue Type: Bug
            Reporter: Ryan McGuire


Cassandra fails to start with openjdk with the error:

{code}
Cassandra 2.0 and later require Java 7u25 or later.
{code}

This commit broke it:

https://github.com/apache/cassandra/commit/87548095859c210e7be8cc8bbb4a5aa1f857a6ad

My openjdk version string looks like:

{code}
vagrant@cnode1:~/fab/cassandra$ java -version
openjdk version "1.7.0-u60-unofficial"
OpenJDK Runtime Environment (build 1.7.0-u60-unofficial-b30)
OpenJDK 64-Bit Server VM (build 24.60-b09, mixed mode)
{code}

Which this change does not parse properly.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message