cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Stepura (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-7509) conditional updates don't work from cqlsh
Date Sat, 12 Jul 2014 12:50:04 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-7509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mikhail Stepura updated CASSANDRA-7509:
---------------------------------------

    Attachment: CASSANDRA-2.1.0-7509.patch

I'm attaching the patch for 2.1.0. It contains bundled python-driver 2.0.2 + changes for https://datastax-oss.atlassian.net/browse/PYTHON-90,
as well as a new dependency.

There are still few failing cqlsh tests, but those are not related to the new driver, we'll
address them later.

> conditional updates don't work from cqlsh
> -----------------------------------------
>
>                 Key: CASSANDRA-7509
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-7509
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Tools
>            Reporter: Jeremiah Jordan
>            Assignee: Mikhail Stepura
>            Priority: Blocker
>             Fix For: 2.1.0
>
>         Attachments: CASSANDRA-2.1.0-7509.patch
>
>
> {noformat}
> apache-cassandra-2.1.0-rc2/bin $ ./cqlsh
> Connected to Test Cluster at 127.0.0.1:9042.
> [cqlsh 5.0.1 | Cassandra 2.1.0-rc2 | CQL spec 3.1.7 | Native protocol v3]
> Use HELP for help.
> cqlsh> use ks1;
> cqlsh:ks1> create table users(
>        ... userID uuid,
>        ... fname text,
>        ... lname text,
>        ... email text,
>        ... address text,
>        ... zip int,
>        ... state text,
>        ... PRIMARY KEY ((userID, fname), state)
>        ... );
> cqlsh:ks1> insert into users (userID, fname, state, email) VALUES (cfd66ccc-d857-4e90-b1e5-df98a3d40cd6,
'laura', 'ca', 'lauras@gmail.com') if not exists;
> code=2200 [Invalid query] message="Conditional updates are not supported by the protocol
version in use. You need to upgrade to a driver using the native protocol v2."
> cqlsh:ks1>
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message