cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedict (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-7421) CompoundSparseCellName/WithCollection report smaller heap sizes then actual
Date Fri, 20 Jun 2014 10:18:25 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-7421?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Benedict updated CASSANDRA-7421:
--------------------------------

    Attachment: 7421v2.patch

Does need tidying up, but we should avoid using ObjectSizes.measure() for two reasons:

# The ColumnIdentifier for compound sparse tables are always shared / declared (to my knowledge
- only sparse tables permit dynamic column names)
# It's very expensive, so even if they weren't we should prefer columnName.unsharedHeapSize()

I've taken this opportunity to finally tidy up the mismatched naming of unshared vs excess
heap size methods (some were renamed as part of bikeshedding their first commit, but some
were missed)

> CompoundSparseCellName/WithCollection report smaller heap sizes then actual 
> ----------------------------------------------------------------------------
>
>                 Key: CASSANDRA-7421
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-7421
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>            Reporter: Dave Brosius
>            Assignee: Dave Brosius
>            Priority: Trivial
>             Fix For: 2.1 rc2
>
>         Attachments: 7421.txt, 7421v2.patch
>
>
> Class relies on sizing of super class, which doesn't take into consideration it's own
foot print, along with it's excess fields.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message