cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Stepura (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-6307) Switch cqlsh from cassandra-dbapi2 to python-driver
Date Tue, 11 Mar 2014 22:15:49 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-6307?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13931047#comment-13931047
] 

Mikhail Stepura commented on CASSANDRA-6307:
--------------------------------------------

thanks [~thobbs].

I've also discovered that Python 2.7.x can't connect to the Cassandra running in Java 7, if
Cassandra's keypair was generated using instructions from (http://www.datastax.com/documentation/cassandra/2.0/cassandra/security/secureSSLCertificates_t.html?scroll=task_ds_c14_xjy_2k):
{{keytool -genkey -alias <cassandra_node0> -keystore .keystore}}

In this case Python will fail with {{SSLError(1, '_ssl.c:507: error:14094410:SSL routines:SSL3_READ_BYTES:sslv3
alert handshake failure')}}

So I had to generate keys with {{-keyalg RSA}}  to work around that. Not sure what how that
will impact existing setups.

http://stackoverflow.com/questions/14167508/intermittent-sslv3-alert-handshake-failure-under-python
suggests to {{disable DHE cipher suites (at either end)}}, so I'll try to do that at the cqlsh
side.


> Switch cqlsh from cassandra-dbapi2 to python-driver
> ---------------------------------------------------
>
>                 Key: CASSANDRA-6307
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-6307
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Aleksey Yeschenko
>            Assignee: Mikhail Stepura
>            Priority: Minor
>             Fix For: 2.1 beta2
>
>
> python-driver is hitting 1.0 soon. cassandra-dbapi2 development has stalled.
> It's time to switch cqlsh to native protocol and cassandra-dbapi2, especially now that
> 1. Some CQL3 things are not supported by Thrift transport
> 2. cqlsh no longer has to support CQL2 (dropped in 2.0)



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message