cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sylvain Lebresne (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-6689) Partially Off Heap Memtables
Date Fri, 28 Feb 2014 17:06:20 GMT


Sylvain Lebresne commented on CASSANDRA-6689:

bq. There are a lot of these methods, and putting "internal" as a prefix or something else
doesn't seem any better to me.

Well, it's more consistent with the code style, and consistency is better. It's imo also more
explicit since you had to use the word "internal" to describe what the underscore were standing
for in your comment. And if size() and _size() "mean two completely different things", I think
having more than one character separating them is not a bad thing. But honestly the latter
points are almost irrelevant, code base style consistency is (to me at least).

> Partially Off Heap Memtables
> ----------------------------
>                 Key: CASSANDRA-6689
>                 URL:
>             Project: Cassandra
>          Issue Type: New Feature
>          Components: Core
>            Reporter: Benedict
>            Assignee: Benedict
>             Fix For: 2.1 beta2
> Move the contents of ByteBuffers off-heap for records written to a memtable.
> (See comments for details)

This message was sent by Atlassian JIRA

View raw message