cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward Capriolo (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-6147) Break timestamp ties for thrift-ers
Date Fri, 04 Oct 2013 15:33:43 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-6147?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Edward Capriolo updated CASSANDRA-6147:
---------------------------------------

    Environment: 
Thrift users are still forced to generate timestamps on the client side. Currently the way
the thrift bindings are generated users are forced to supply timestamps. There are two solutions
I see.
* -1 as timestamp means "generate on the server side"
This is a breaking change, for those using -1 as a timestamp (which should effectively be
no one.
* Prepare yourself....
Our thrift signatures are wrong, you can't overload methods in thrift

thrift.get(byte [], byte[], ts) 

should REALLY be changed to 

GetRequest g =  new GetRequest()
g.setName()
g.setValue()
g.setTs() ///optional 
thrift. get( g )

I know no one is going to want to make this change because thrift is quasi/dead but it would
allow us to evolve thrift in a meaningful way. We could simple add these new methods under
different names as well.

> Break timestamp ties for thrift-ers
> -----------------------------------
>
>                 Key: CASSANDRA-6147
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-6147
>             Project: Cassandra
>          Issue Type: Sub-task
>         Environment: Thrift users are still forced to generate timestamps on the client
side. Currently the way the thrift bindings are generated users are forced to supply timestamps.
There are two solutions I see.
> * -1 as timestamp means "generate on the server side"
> This is a breaking change, for those using -1 as a timestamp (which should effectively
be no one.
> * Prepare yourself....
> Our thrift signatures are wrong, you can't overload methods in thrift
> thrift.get(byte [], byte[], ts) 
> should REALLY be changed to 
> GetRequest g =  new GetRequest()
> g.setName()
> g.setValue()
> g.setTs() ///optional 
> thrift. get( g )
> I know no one is going to want to make this change because thrift is quasi/dead but it
would allow us to evolve thrift in a meaningful way. We could simple add these new methods
under different names as well.
>            Reporter: Edward Capriolo
>            Assignee: Edward Capriolo
>             Fix For: 2.1
>
>




--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message