cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom van den Berge (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-4785) Secondary Index Sporadically Doesn't Return Rows
Date Mon, 07 Oct 2013 19:29:56 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-4785?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13788480#comment-13788480
] 

Tom van den Berge commented on CASSANDRA-4785:
----------------------------------------------

I'm seeing this problem, too, (cassandra 1.2.3), but my CF has caching KEYS_ONLY. It only
happens to specific rows in the CF; not all. Also, it only happens on one single node in my
2-node cluster (replication factor 2). 

Storing the indexed value again solves the problem for this particular row, but I've seen
this problem happen several times now, even on the same rows -- also after having "fixed"
it as I just described. I'm not 100% sure, but I think the problem occurred again after having
rebuilt the node.

> Secondary Index Sporadically Doesn't Return Rows
> ------------------------------------------------
>
>                 Key: CASSANDRA-4785
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-4785
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.1.5, 1.1.6
>         Environment: Ubuntu 10.04
> Java 6 Sun
> Cassandra 1.1.5 upgraded from 1.1.2 -> 1.1.3 -> 1.1.5
>            Reporter: Arya Goudarzi
>            Assignee: Sam Tunnicliffe
>         Attachments: entity_aliases.txt, repro.py
>
>
> I have a ColumnFamily with caching = ALL. I have 2 secondary indexes on it. I have noticed
if I query using the secondary index in the where clause, sometimes I get the results and
sometimes I don't. Until 2 weeks ago, the caching option on this CF was set to NONE. So, I
suspect something happened in secondary index caching scheme. 
> Here are things I tried:
> 1. I rebuild indexes for that CF on all nodes;
> 2. I set the caching to KEYS_ONLY and rebuild the index again;
> 3. I set the caching to NONE and rebuild the index again;
> None of the above helped. I suppose the caching still exists as this behavior looks like
cache mistmatch.
> I did a bit research, and found CASSANDRA-4197 that could be related.
> Please advice.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message