cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ananth Gundabattula (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CASSANDRA-5684) Multi-DC not working between 1.1.10 and 1.2.4 version
Date Fri, 21 Jun 2013 11:26:19 GMT
Ananth Gundabattula created CASSANDRA-5684:
----------------------------------------------

             Summary: Multi-DC not working between 1.1.10 and 1.2.4 version
                 Key: CASSANDRA-5684
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-5684
             Project: Cassandra
          Issue Type: Bug
          Components: Core
    Affects Versions: 1.2.4
         Environment: Linux
            Reporter: Ananth Gundabattula


We wanted to upgrade to a higher version of cassandra ( a custom build of 1.2.4 ) from current
cassandra version 1.1.10.

The way we wanted to upgrade is to build a new cluster and enable multi-dc replication; rebuild
and switch the application layer to the new cluster. This enabled us to have the least downtime.


However, I was not able to get a multi-dc going between these two versions. I followed pretty
much the instructions here ( for the 1.2.4 version ) http://www.datastax.com/documentation/cassandra/1.2/index.html#cassandra/operations/ops_add_dc_to_cluster_t.html.
I tried enabling multi-dc using these instructions for the 1.1.10 cluster http://www.datastax.com/docs/1.0/initialize/cluster_init_multi_dc

Mixing both the approaches did not work either. Specifying a 1.2.4 node as one of the 1.1.10
cluster seed nodes caused errors in the startup of 1.2.4 node. The error was not an exception
but a message looking like this in the logs : ClusterName mismatch from /10.xxx.xx.xx DC1!=DC2



--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message