cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Tennant (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-4785) Secondary Index Sporadically Doesn't Return Rows
Date Wed, 19 Jun 2013 22:16:20 GMT


Chris Tennant commented on CASSANDRA-4785:

I noticed this or similar problem after changing caching on the table from default 'keys_only'
to 'all' using 'alter table' -- neither of the two secondary indexes on the table then returned
any rows.   Before the alter table to change caching, both secondary indexes worked every
time.  After I made the change, neither of the indexes ever returned any rows (so not sporadic
for me). Rebuilding the indexes using nodetool after the caching change didn't help.  I did
not try dropping the index and re-adding it. 

Altering the table back to 'keys_only' didn't help, even when I rebuild the indexes after
the move back to 'keys_only'.

Recreating the tables with 'keys_only' caching solved the problem.
> Secondary Index Sporadically Doesn't Return Rows
> ------------------------------------------------
>                 Key: CASSANDRA-4785
>                 URL:
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.1.5, 1.1.6
>         Environment: Ubuntu 10.04
> Java 6 Sun
> Cassandra 1.1.5 upgraded from 1.1.2 -> 1.1.3 -> 1.1.5
>            Reporter: Arya Goudarzi
> I have a ColumnFamily with caching = ALL. I have 2 secondary indexes on it. I have noticed
if I query using the secondary index in the where clause, sometimes I get the results and
sometimes I don't. Until 2 weeks ago, the caching option on this CF was set to NONE. So, I
suspect something happened in secondary index caching scheme. 
> Here are things I tried:
> 1. I rebuild indexes for that CF on all nodes;
> 2. I set the caching to KEYS_ONLY and rebuild the index again;
> 3. I set the caching to NONE and rebuild the index again;
> None of the above helped. I suppose the caching still exists as this behavior looks like
cache mistmatch.
> I did a bit research, and found CASSANDRA-4197 that could be related.
> Please advice.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message