cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Williams (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-5333) dynamic snitch only worked for NetworkTopology due to RemoteNode
Date Mon, 11 Mar 2013 20:07:14 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-5333?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13599205#comment-13599205
] 

Brandon Williams commented on CASSANDRA-5333:
---------------------------------------------

Care to say where in the code the issue is, since you dug in?
                
> dynamic snitch only worked for NetworkTopology due to RemoteNode
> ----------------------------------------------------------------
>
>                 Key: CASSANDRA-5333
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-5333
>             Project: Cassandra
>          Issue Type: Bug
>    Affects Versions: 1.2.2
>         Environment: redhat linux.  we dug into the code though and it appears to be
the way it is coded.  we were told to file a ticket for this on the email list.
>            Reporter: Dean Hiller
>              Labels: snitch
>
> We dug into cassandra code and found out SimpleSnitch was not working with DynamicSnitch.
 Specifically, the code turns a slow node into a remote node and network topology works with
that.  We also had to move to LOCAL_QUOROM and finally we have dynamic snitch working.  To
test this, we basically told the NIC using the "tc" command to slow every packet down by 500ms
on node 2 (out of 4 nodes).  We finally have a blazingly fast client with node 2 slowed down.
 If we do QUOROM, the issue comes back and the client is slow again.  Same with SimpleSnitch.
 To reproduce, run a 4 node cluster and use "tc" to give every packet a slowdown of 500ms.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message