cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Cruz (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-4785) Secondary Index Sporadically Doesn't Return Rows
Date Wed, 13 Feb 2013 18:42:13 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-4785?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13577813#comment-13577813
] 

André Cruz commented on CASSANDRA-4785:
---------------------------------------

I also have caching=ALL on this CF. Nothing else was needed?

Because I've already tried invalidating key and row caches and the problem remains. Did you
restart the nodes, repaired or did anything else?
                
> Secondary Index Sporadically Doesn't Return Rows
> ------------------------------------------------
>
>                 Key: CASSANDRA-4785
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-4785
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.1.5, 1.1.6
>         Environment: Ubuntu 10.04
> Java 6 Sun
> Cassandra 1.1.5 upgraded from 1.1.2 -> 1.1.3 -> 1.1.5
>            Reporter: Arya Goudarzi
>
> I have a ColumnFamily with caching = ALL. I have 2 secondary indexes on it. I have noticed
if I query using the secondary index in the where clause, sometimes I get the results and
sometimes I don't. Until 2 weeks ago, the caching option on this CF was set to NONE. So, I
suspect something happened in secondary index caching scheme. 
> Here are things I tried:
> 1. I rebuild indexes for that CF on all nodes;
> 2. I set the caching to KEYS_ONLY and rebuild the index again;
> 3. I set the caching to NONE and rebuild the index again;
> None of the above helped. I suppose the caching still exists as this behavior looks like
cache mistmatch.
> I did a bit research, and found CASSANDRA-4197 that could be related.
> Please advice.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message