cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alain RODRIGUEZ (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-5111) StackOverflowError after upgrading to Cassandra 1.2.0
Date Fri, 04 Jan 2013 16:40:12 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-5111?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13544002#comment-13544002
] 

Alain RODRIGUEZ commented on CASSANDRA-5111:
--------------------------------------------

I had the following in my cassandra-env.sh: startswith() { [ "${1#$2}" != "$1" ]; }

if [ "`uname`" = "Linux" ] ; then
    # reduce the per-thread stack size to minimize the impact of Thrift
    # thread-per-client.  (Best practice is for client connections to
    # be pooled anyway.) Only do so on Linux where it is known to be
    # supported.
    if startswith "$JVM_VERSION" '1.7.'
    then
        JVM_OPTS="$JVM_OPTS -Xss160k"
    else
        JVM_OPTS="$JVM_OPTS -Xss160k"
    fi
fi

This looks like the Cassandra 1.1.6 except that the first condition should be -Xss180k. I
Obviously made some change I forgot to remove.

That's my bad, sorry for wasting your time. How did you know about the -Xss ? I mean how could
I have debug it by myself ?

                
> StackOverflowError after upgrading to Cassandra 1.2.0
> -----------------------------------------------------
>
>                 Key: CASSANDRA-5111
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-5111
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.2.0
>         Environment: Ubuntu 12.04
> java version "1.6.0_35"
> Java(TM) SE Runtime Environment (build 1.6.0_35-b10)
> Java HotSpot(TM) 64-Bit Server VM (build 20.10-b01, mixed mode)
> java-1.6.0-openjdk-amd64 1061 /usr/lib/jvm/java-1.6.0-openjdk-amd64
> Hardware: intel i5 / 8GB RAM
> Multiple clients (phpCassa, Twitter-Cassie, Helenus, Hector...)
>            Reporter: Alain RODRIGUEZ
>              Labels: 1.2.0, StackOverflowError, cassandra, update, upgrade
>         Attachments: logs-dev.txt
>
>
> After upgrading C* from 1.1.7 to 1.2.0 I have a java.lang.StackOverflowError message
error on my one node dev cluster.
> I changed the heap size from 3 GB to 2 GB (auto/default) considering bloomfilters are
now out of the heap.
> I think this was the only changes I have made (upgrade & reduce the heap)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message