cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremy Hanna (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CASSANDRA-4350) cql cassandra version reporting is incorrect
Date Wed, 12 Sep 2012 21:57:08 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-4350?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jeremy Hanna resolved CASSANDRA-4350.
-------------------------------------

    Resolution: Cannot Reproduce

I tried to reproduce with cassandra 1.0.10 as the cluster version and tried cqlsh from 1.0.8,
1.0.9, and 1.0.11.  All three when starting reported the correct version (1.0.10) of the instance
it connected to.  Resolving this as cannot reproduce.
                
> cql cassandra version reporting is incorrect
> --------------------------------------------
>
>                 Key: CASSANDRA-4350
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-4350
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Jeremy Hanna
>            Assignee: paul cannon
>            Priority: Minor
>              Labels: cql, cqlsh
>
> It looks like either the docs are wrong or the functionality is wrong.  The docs for
show version say:
> {quote}
> Shows the version and build of the connected Cassandra instance, well as the versions
of the CQL spec and the Thrift protocol that the connected Cassandra instance understands.
> {quote}
> On a cassandra node in the ring, I do nodetool -h localhost version and it outputs the
correct version (1.0.8).  From a remote node with 1.0.9 installed, I run nodetool -h <same_node_in_ring>
version.  It outputs the correct version.  However when I start cqlsh, it shows the remote
node's version (1.0.9).  Also when I use the 'show version;' command in cqlsh, it also prints
out 1.0.9.
> So either the docs are incorrect and it just outputs the version of the local build or
there's a bug in show version and the startup output and it should really show the version
of the connected node.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message