cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Terrance Shepherd (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CASSANDRA-4498) Remove openjdk-6-jre Cassandra APT dependencies
Date Wed, 08 Aug 2012 18:08:20 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-4498?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13431259#comment-13431259
] 

Terrance Shepherd edited comment on CASSANDRA-4498 at 8/8/12 6:08 PM:
----------------------------------------------------------------------

There really are 4 solutions

1) keep things as they are and everyone downloads an additional 100mb of openjdk and possibly
mess up an already installed jre
2) update docs to use equivs which could complicate things and doesn't solve the ultimate
problem.
3) make the recommended change and update the docs to use apt-get (--install-recommends |
--install-suggests) for people without a jvm installed
4) make the recommended change and update the docs to use apt-get install openjdk-6-jre cassandra
for people without a jvm installed

Obviously my recommended solution of 3 or 4, I believe is the cleanest.
                
      was (Author: tscanausa):
    There really are 4 solutions

1) keep things as they are and everyone downloads an additional 100mb of openjdk and possibly
mess up an already installed jre
2) update docs to use equivs which could complicate things and doesn't solve the ultimate
problem.
3) make the recommended change and update the docs to use apt-get (--install-recommends|--install-suggests)
for people without a jvm installed
4) make the recommended change and update the docs to use apt-get install openjdk-6-jre cassandra
for people without a jvm installed

Obviously my recommended solution of 3 or 4, I believe is the cleanest.
                  
> Remove openjdk-6-jre Cassandra APT dependencies
> -----------------------------------------------
>
>                 Key: CASSANDRA-4498
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-4498
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Terrance Shepherd
>            Assignee: paul cannon
>            Priority: Minor
>              Labels: debian
>             Fix For: 1.1.4, 1.2
>
>         Attachments: apache_cassandra_Packages.diff
>
>
> As it is well known the recommended jre for Cassandra is sun java 1.6 but at this point
that package no longer in the debian or ubuntu apt repos. In order to run Cassandra with the
sun java 1.6 jre it must be installed manually with out the repos. Because of this when you
install cassandra via the apache or datastax apt repos it must also install openjdk-6-jre
even though sun java 1.6 jre is already installed.
> I would suggest that the java apt dependencies be removed from the Depends field in package
configuration and move to either the Recommends or Suggests field so that way openjdk is not
being downloaded when not necessary and possibly interfering with a be pre-installed jre

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message