cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Drew Kutcharian (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-4081) Issue with cassandra-cli "assume" command and custom types
Date Sat, 24 Mar 2012 20:40:26 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-4081?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13237662#comment-13237662
] 

Drew Kutcharian commented on CASSANDRA-4081:
--------------------------------------------

Seems like, but I'd really prefer if I can pass in a fqn of a class. We are storing Jackson
Smile encoded blobs as bytes in Cassandra but we would like to be able to get a human friendly
output from cassandra-cli.
                
> Issue with cassandra-cli "assume" command and custom types
> ----------------------------------------------------------
>
>                 Key: CASSANDRA-4081
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-4081
>             Project: Cassandra
>          Issue Type: Bug
>    Affects Versions: 1.0.7
>         Environment: Cassandra 1.0.7 on Mac OSX Lion
>            Reporter: Drew Kutcharian
>
> There seems to be an issue with cassandra-cli's assume command with a custom type. I
get "Syntax error at position 35: missing EOF at '.'"
> To make sure the issue is not with my custom type, I tried it with the built-in BytesType
and got the same error:
> [default@test] assume UserDetails validator as org.apache.cassandra.db.marshal.BytesType;
> Syntax error at position 35: missing EOF at '.'
> I also tried it with single and double quotes with no success:
> [default@test] assume UserDetails validator as 'org.apache.cassandra.db.marshal.BytesType';
> Syntax error at position 32: mismatched input ''org.apache.cassandra.db.marshal.BytesType''
expecting Identifier
> Based on the output of "help assume" I should be able to just pass a fqn of a class.
> > It is also valid to specify the fully-qualified class name to a class that
> > extends org.apache.Cassandra.db.marshal.AbstractType.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message