cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wenjun (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-4078) StackOverflowError when upgrading to 1.0.8 from 0.8.10
Date Fri, 30 Mar 2012 16:22:29 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-4078?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13242499#comment-13242499
] 

Wenjun commented on CASSANDRA-4078:
-----------------------------------

Paul, yes, finally I am able to narrow it down to this one CF.  I truncated data from all
other CFs, ran 'cleanp' and 'scrub', and it is still happening.  What else can I do to help
debugging this issue?  The followings are definition of this CF:

    ColumnFamily: UserAgreementStatus
      Key Validation Class: org.apache.cassandra.db.marshal.BytesType
      Default column value validator: org.apache.cassandra.db.marshal.BytesType
      Columns sorted by: org.apache.cassandra.db.marshal.UTF8Type
      Row cache size / save period in seconds: 0.0/0
      Row Cache Provider: org.apache.cassandra.cache.ConcurrentLinkedHashCacheProvider
      Key cache size / save period in seconds: 200000.0/14400
      Memtable thresholds: 0.45468749999999997/1440/97 (millions of ops/minutes/MB)
      GC grace seconds: 864000
      Compaction min/max thresholds: 4/32
      Read repair chance: 1.0
      Replicate on write: false
      Built indexes: [UserAgreementStatus.userId]
      Column Metadata:
        Column Name: agreementName
          Validation Class: org.apache.cassandra.db.marshal.UTF8Type
        Column Name: response
          Validation Class: org.apache.cassandra.db.marshal.UTF8Type
        Column Name: userId
          Validation Class: org.apache.cassandra.db.marshal.LexicalUUIDType
          Index Name: userId
          Index Type: KEYS
        Column Name: viewTime
          Validation Class: org.apache.cassandra.db.marshal.LongType

Log right before the exception:
DEBUG [SSTableBatchOpen:2] 2012-03-30 12:09:20,277 SSTableReader.java (line 190) INDEX LOAD
TIME for /home/cassandra/var/lib/cassandra/d
ata/Appoji/UserAgreementStatus.userId-f-56: 3 ms.
DEBUG [SSTableBatchOpen:2] 2012-03-30 12:09:20,277 SSTableReader.java (line 193) key cache
contains 0/0 keys



                
> StackOverflowError when upgrading to 1.0.8 from 0.8.10
> ------------------------------------------------------
>
>                 Key: CASSANDRA-4078
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-4078
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 0.8.10
>         Environment: OS: Linux xps.openfin 2.6.35.13-91.fc14.i686 #1 SMP Tue May 3 13:36:36
UTC 2011 i686 i686 i386 GNU/Linux
> Java: JVM vendor/version: Java HotSpot(TM) Server VM/1.6.0_31
>            Reporter: Wenjun
>            Assignee: paul cannon
>            Priority: Critical
>             Fix For: 0.8.10
>
>         Attachments: 4078.add-asserts.txt, cassandra.yaml.1.0.8, cassandra.yaml.8.10,
system.log, system.log.0326, system.log.0326-02
>
>
> Hello
> I am trying to upgrade our 1-node setup from 0.8.10 to 1.0.8 and seeing the following
exception when starting up 1.0.8.  We have been running 0.8.10 without any issues.
>  
> Attached is the entire log file during startup of 1.0.8.  There are 2 exceptions:
> 1. StackOverflowError (line 2599)
> 2. InstanceAlreadyExistsException (line 3632)
> I tried "run scrub" under 0.8.10 first, it did not help.  Also, I tried dropping the
column family which caused the exception, it just got the same exceptions from another column
family.
> Thanks

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message