cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Donald Smith (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-3663) Change syntax of cqlsh for creating column families to be more descriptive for "comparator" and "default_validation"
Date Thu, 22 Dec 2011 20:43:30 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-3663?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13175043#comment-13175043
] 

Donald Smith commented on CASSANDRA-3663:
-----------------------------------------

I agree.  "column_value_validator" is better than "column_value_validation". It's more parallel
with "column_name_comparator".
                
> Change syntax of cqlsh for creating column families to be more descriptive for "comparator"
and "default_validation"
> --------------------------------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-3663
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-3663
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>            Reporter: Donald Smith
>            Priority: Minor
>
> According to http://crlog.info/2011/09/17/cassandra-query-language-cql-v2-0-reference/#Column+Family+Options+%28optional%29
> the syntax for creating column families in cqlsh uses keywords
>     "comparator"  and "default_validation".
> Better, more descriptive names for these would be
>     "column_name_comparator"  and "column_value_validation"
> or perhaps better yet
>     "column_key_comparator"  and "column_value_validation".
> Two other people on the cassandra users' mailing list agreed with this suggestion.
> The existing syntax is unclear and confusing to beginners.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message