cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sylvain Lebresne (JIRA)" <>
Subject [jira] Updated: (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)
Date Wed, 19 Jan 2011 16:02:44 GMT


Sylvain Lebresne updated CASSANDRA-2009:

    Attachment: 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

Attaching a bunch of patches against 0.7. I've separated them in what I though
were reasonably logical units. Those are all fairly trivial refactorings and
are proposed refactorings only. But I think they make sense.
More infos on the patch:
  * 0001: Move byteBufferToInt() and toByteBuffer([int|long]) and simplify
    their implementation. Also rename them to match more closely the
    equivalent methods on strings.
  * 0002: Move readByteArray() and alike and rename them to match the write
    methods (already in ByteBufferUtil).
  * 0003: Move inputStream. I also changed the implementation so that it uses
    a duplicate() instead of a clone() (didn't saw the point of the full
    cloning). Still probably worth a second eye.
  * 0004: Move hexToByte and bytesToHex. Actually, since we use both those
    function on ByteBuffers and byte arrays, I've moved the version on
    ByteBuffer in ByteBufferUtil but left the other in FBUtilities.

> Move relevant methods to ByteBufferUtil (and normalize on names)
> ----------------------------------------------------------------
>                 Key: CASSANDRA-2009
>                 URL:
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Sylvain Lebresne
>            Assignee: Sylvain Lebresne
>            Priority: Trivial
>             Fix For: 0.7.1
>         Attachments: 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch,
0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch,
>   Original Estimate: 4h
>  Remaining Estimate: 4h
> A number of methods are in FBUtilities while they more naturally belong to
> ByteBufferUtil. Moreover, their naming convention conflict with some of the
> method already moved to ByteBufferUtil.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message